Error de Joomla: Database Error: Unable to connect to the database:Could not connect to MySQL
Joomla utiliza una base de datos. Si por algún motivo no consigue conectarse a ella, puede recibir este mensaje:
Database Error: Unable to connect to the database:Could not connect to MySQL
En configuration.php (que se encuentra en la carpeta donde está instalado Joomla) encontrará estos ajustes para conectar con la base de datos:
var $host = 'localhost'; // Siempre es localhost
var $user = 'XXX_ZZZ'; // En XXX va el nombre de usuario del panel de control, en ZZZ el usuario de la base de datos
var $db = 'XXX_YYY'; // En XXX va el nombre de usuario del panel de control, en YYY el nombre de la base de datos
var $password = 'contraseña'; // La contraseña que asignó al usuario de la base de datos
Si no puede conectarse, probablemente haya algún error en los datos anteriores.
Inicie sesión en el panel de control y elija el menú MySQL. Después elija la base de datos de Joomla (haciendo clic en ella) y se mostrarán los usuarios de base de datos existentes. Si lo desea, cree un nuevo usuario de base de datos e introduzca ese nombre de usuario y esa contraseña en configuration.php. Si el usuario ya existe, cambie la contraseña por seguridad para que coincida también con configuration.php.
Por cierto, si instaló Joomla con Installatron, también puede averiguar el nombre de la base de datos desde Installatron.
